Email setup and communication tab not functioning
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted May 04, 2023 - 14:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2023 - 13:54 PDT
This incident affected: Email (Email blasts).