Issues with email blasts not being delivered
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 07:03 PDT
Monitoring
The issue has been identified, a fix has been implemented and email blasts have resumed sending.
Posted Apr 03, 2023 - 20:38 PDT
Update
We are continuing to investigate the issue. There is no need to re send email blasts at this time.
Posted Apr 03, 2023 - 19:49 PDT
Update
We are continuing to investigate this issue.
Posted Apr 03, 2023 - 18:38 PDT
Investigating
We are currently investigating an issue with email blasts not being delivered.
Posted Apr 03, 2023 - 17:53 PDT
This incident affected: Email (Email blasts).